Scrapy up to 1.8.0/2.5.0 HttpAuthMiddleware w3lib.http.basic_auth_header http_user/http_pass information disclosure

A vulnerability was found in Scrapy up to 1.8.0/2.5.0 and classified as problematic. This issue affects the function w3lib.http.basic_auth_header of the component HttpAuthMiddleware. Upgrading to version 1.8.1 or 2.5.1 eliminates this vulnerability. Applying the patch b01d69a1bf48060daec8f751368622352d8b85a6 is able to eliminate this problem. The bugfix is ready for download at github.com. The best possible mitigation is suggested to be upgrading to the latest version.

Common Vulnerabilityies and Exposures

Contact us to get started

CVE-2024-21513 : LANGCHAIN-EXPERIMENTAL UP TO 0.0.20 DATABASE EVAL CODE INJECTION

CVE-2024-21513 : LANGCHAIN-EXPERIMENTAL UP TO 0.0.20 DATABASE EVAL CODE INJECTION

Description Versions of the package langchain-experimental from 0.0.15 and before 0.0.21 are vulnerable to Arbitrary Code Execution when retrieving values

CVE-2024-6737 : 2100 TECHNOLOGY ELECTRONIC OFFICIAL DOCUMENT MANAGEMENT SYSTEM UP TO 5.0.76 SETTING ACCESS CONTROL

CVE-2024-6737 : 2100 TECHNOLOGY ELECTRONIC OFFICIAL DOCUMENT MANAGEMENT SYSTEM UP TO 5.0.76 SETTING ACCESS CONTROL

Description The access control in the Electronic Official Document Management System from 2100 TECHNOLOGY is not properly implemented, allowing remote

CVE-2024-6345 : PYPA SETUPTOOLS UP TO 69.1.1 PACKAGE_INDEX CODE INJECTION

CVE-2024-6345 : PYPA SETUPTOOLS UP TO 69.1.1 PACKAGE_INDEX CODE INJECTION

Description A vulnerability in the package_index module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its