passport-oauth2 up to 1.6.0 on Node.js OAuth Identity Provider improper authentication [Disputed]

A vulnerability was found in passport-oauth2 up to 1.6.0 on Node.js (JavaScript Library). It has been classified as critical. Affected is an unknown function of the component OAuth Identity Provider Handler. Upgrading to version 1.6.1 eliminates this vulnerability. The upgrade is hosted for download at github.com. Applying the patch 8e3bcdff145a2219033bd782fc517229fe3e05ea is able to eliminate this problem. The bugfix is ready for download at github.com. The best possible mitigation is suggested to be upgrading to the latest version.

Common Vulnerabilityies and Exposures

Django up to 2.2.24/3.1.13/3.2.9 HTTP Request access control

A vulnerability was found in Django up to 2.2.24/3.1.13/3.2.9 (Content Management System). It has been classified as critical. This affects some unknown processing of the component HTTP Request Handler. Upgrading to version 2.2.25, 3.1.14 or 3.2.10 eliminates this vulnerability. The upgrade is hosted for download at djangoproject.com.

WSO2 Identity Server 5.7.0 Password Reset recoverpassword.do callback password recovery

A vulnerability was found in WSO2 Identity Server 5.7.0. It has been declared as critical. This vulnerability affects an unknown function of the file accountrecoveryendpoint/recoverpassword.do of the component Password Reset Handler. There is no information about possible countermeasures known. It may be suggested to replace the affected object with an […]

Apereo CAS up to 6.4.1 REST API Endpoint cross site scripting

A vulnerability was found in Apereo CAS up to 6.4.1. It has been rated as problematic. This issue affects an unknown functionality of the component REST API Endpoint. There is no information about possible countermeasures known. It may be suggested to replace the affected object with an alternative product.