AWS Firecracker through v0.19.0 has a Buffer Overflow vuln

Overview :
A logical error in bounds checking performed on vsock virtio descriptors can be used by a malicious guest to read from and write to a segment of the host-side Firecracker process’ heap address space, directly after the end of a guest memory region. For reads, the accessible segment’s size is 64 KiB. For writes, the accessible segment is limited by the host Linux kernel to a size defined in /proc/sys/net/core/rmem_max. We expect the value of rmem_max to be on the order of a few hundred KiB to a few MiB.
Affected Product(s) :
  • Firecracker v0.18.0 and v0.19.0
Vulnerability Details :
CVE ID : CVE-2019-18960
This will generally result in a segmentation fault, but remote code execution within the Firecracker host-side process context cannot be ruled out.

Only Firecracker v0.18.0 and v0.19.0 are affected. Only Firecracker microVMs with configured vsock devices are affected, and only if one or more vsock devices are in active use by both host and guest.

Remediation / Fixes :

Patched binaries for the affected versions have been released as Firecracker v0.18.1 and Firecracker v0.19.1 . If you are using Firecracker v0.18.0 or v0.19.0 , we recommend you apply the provided fix. If you are using Firecracker v0.17.0 or below, you do not need to take any action.

In a remote code execution scenario, users running Firecracker in line with the recommended Production Host Setup will see the impact limited as follows: a malicious microVM guest that would manage to compromise the Firecracker VMM process would be restricted to running on the host as an unprivileged user, in a chroot and mount namespace isolated from the host’s filesystem, in a separate pid namespace, in a separate network namespace, with system calls limited to Firecracker’s seccomp whitelist, on a single NUMA node, and on a cgroups-limited number of CPU cores.

https://github.com/firecracker-microvm/firecracker/releases/tag/v0.18.1

https://github.com/firecracker-microvm/firecracker/releases/tag/v0.19.1

Common Vulnerabilityies and Exposures

Contact us to get started

CVE-2022-41157 : KYUNGRINARA ERP SOLUTION SERP SERVER HARD-CODED CREDENTIALS

CVE-2022-41157 : KYUNGRINARA ERP SOLUTION SERP SERVER HARD-CODED CREDENTIALS

Description A specific file on the sERP server if Kyungrinara(ERP solution) has a fixed password with the SYSTEM authority. This

CVE-2022-45884 : LINUX KERNEL UP TO 6.0.9 DVBDEV.C DVB_REGISTER_DEVICE USE AFTER FREE

CVE-2022-45884 : LINUX KERNEL UP TO 6.0.9 DVBDEV.C DVB_REGISTER_DEVICE USE AFTER FREE

Description An issue was discovered in the Linux kernel through 6.0.9. drivers/media/dvb-core/dvbdev.c has a use-after-free, related to dvb_register_device dynamically allocating

CVE-2022-41875 : OPTICA UP TO 0.10.1 JSON OJ.SAFE_LOAD DESERIALIZATION

CVE-2022-41875 : OPTICA UP TO 0.10.1 JSON OJ.SAFE_LOAD DESERIALIZATION

Description A remote code execution (RCE) vulnerability in Optica allows unauthenticated attackers to execute arbitrary code via specially crafted JSON