Common Vulnerabilities and Exposures

CVE-2023-45898 : LINUX KERNEL UP TO 6.5.3 FS/EXT4/EXTENTS_STATUS.C EXT4_ES_INSERT_EXTENT USE AFTER FREE

CVE-2023-45898 : LINUX KERNEL UP TO 6.5.3 FS/EXT4/EXTENTS_STATUS.C EXT4_ES_INSERT_EXTENT USE AFTER FREE

Description The Linux kernel before 6.5.4 has an es1 use-after-free in fs/ext4/extents_status.c, related to ext4_es_insert_extent. References https://lore.kernel.org/lkml/aa03f191-445c-0d2e-d6d7-0a3208d7df7a%40huawei.com/T/ https://www.spinics.net/lists/stable-commits/msg317086.html https://lkml.org/lkml/2023/8/13/477 https://github.com/torvalds/linux/commit/768d612f79822d30a1e7d132a4d4b05337ce42ec