WordPress 5.2.4 Security Release Breakdown

Zimbabwe Overview :
WordPress released version 5.2.4 as a security release. According to WordPress, WordPress version 5.2.4 fixes 6 security issues.
Affected Product(s) :
  • WordPress released version 5.2.3
Vulnerability Details :
CVE ID : CVE-2019-17675
WordPress before 5.2.3 does not properly consider type confusion during validation of the referer in the admin pages, possibly leading to CSRF.
CVE ID : CVE-2019-17674
WordPress before 5.2.3 is vulnerable to stored XSS (cross-site scripting) via the Customizer.
CVE ID : CVE-2019-17673
WordPress before 5.2.3 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.
CVE ID : CVE-2019-17670
WordPress before 5.2.3 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation of relative URLs.
CVE ID : CVE-2019-17671
In WordPress before 5.2.3, unauthenticated viewing of certain content is possible because the static query property is mishandled.
CVE ID : CVE-2019-17672
WordPress before 5.2.3 is vulnerable to a stored XSS attack to inject JavaScript into STYLE elements.
CVE ID : CVE-2019-17669
WordPress before 5.2.3 has a Server Side Request Forgery (SSRF) vulnerability because URL validation does not consider the interpretation of a name as a series of hex characters.

Solution :
Update to the latest version 5.2.4.

Common Vulnerabilityies and Exposures

Contact us to get started

CVE-2024-5296 : D-LINK D-VIEW 2.0.1.28 TOKENUTILS HARD-CODED KEY

CVE-2024-5296 : D-LINK D-VIEW 2.0.1.28 TOKENUTILS HARD-CODED KEY

Description D-Link D-View Use of Hard-coded Cryptographic Key Authentication Bypass Vulnerability. This vulnerability allows remote attackers to bypass authentication on

CVE-2024-5201 : OPENTEXT DIMENSIONS RM UP TO 12.11.1.2/12.11.2.5 HTTP REQUEST PRIVILEGE ESCALATION

CVE-2024-5201 : OPENTEXT DIMENSIONS RM UP TO 12.11.1.2/12.11.2.5 HTTP REQUEST PRIVILEGE ESCALATION

Description Privilege Escalation in OpenText Dimensions RM allows an authenticated user to escalate there privilege to the privilege of another

CVE-2024-4267 : PARISNEO LOLLMS-WEBUI UP TO 9.5 OPEN_FILE COMMAND INJECTION

CVE-2024-4267 : PARISNEO LOLLMS-WEBUI UP TO 9.5 OPEN_FILE COMMAND INJECTION

Description A remote code execution (RCE) vulnerability exists in the parisneo/lollms-webui, specifically within the ‘open_file’ module, version 9.5. The vulnerability