Overview :
There is a potential information disclosure vulnerability in IBM WebSphere Application Server.
Affected Product(s) :
  • Liberty
  • Version 9.0
  • Version 8.5
  • Version 8.0
  • Version 7.0
Vulnerability Details :
CVE ID : CVE-2019-4441
IBM WebSphere Application Server could allow a remote attacker to obtain sensitive information when a stack trace is returned in the browser.
CVSS Base Score: 5.3
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/163177 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)

Remediation / Fixes :

The recommended solution is to apply the interim fix, Fix Pack or PTF containing the APAR for each named product as soon as practical.

For WebSphere Application Server Liberty using jsp-2.2 or jsp-2.3:

· Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix PH13983
–OR–
· Apply Fix Pack 19.0.0.11 or later (targeted availability 4Q2019).

For WebSphere Application Server traditional and WebSphere Application Server Hypervisor Edition:

For V9.0.0.0 through 9.0.5.1:
· Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix PH13983
–OR–
· Apply Fix Pack 9.0.5.2 or later (targeted availability 4Q2019).

For V8.5.0.0 through 8.5.5.16:
· Upgrade to minimal fix pack levels as required by interim fix and then apply Interim Fix PH13983
–OR–
· Apply Fix Pack 8.5.5.17 or later (targeted availability 1Q2020).

For V8.0.0.0 through 8.0.0.15:
· Upgrade to 8.0.0.15 and then apply Interim Fix PH13983
For V7.0.0.0 through 7.0.0.45:
· Upgrade to 7.0.0.45 and  then apply Interim Fix PH13983
WebSphere Application Server V7.0 and V8.0 are no longer in full support; IBM recommends upgrading to a fixed, supported version/release/platform of the product.