Security Notice for CA Unified Infrastructure Management

Overview :
Multiple issues was discovered in CA Unified Infrastructure Management
Affected Product(s) :
  • UIM product versions 9.20 and below are affected.
  • The robot versions below 7.97HF8, 9.20HF9 and 9.20SHF9 are affected.
Vulnerability Details :
CVE ID : CVE-2020-8012
CA Unified Infrastructure Management (Nimsoft/UIM) 9.20 and below contains a buffer overflow vulnerability in the robot (controller) component. A remote attacker can execute arbitrary code.
CVE ID : CVE-2020-8011
CA Unified Infrastructure Management (Nimsoft/UIM) 9.20 and below contains a null pointer dereference vulnerability in the robot (controller) component. A remote attacker can crash the Controller service.
CVE ID : CVE-2020-8010
CA Unified Infrastructure Management (Nimsoft/UIM) 9.20 and below contains an improper ACL handling vulnerability in the robot (controller) component. A remote attacker can execute commands, read from, or write to the target system.

Solution :

CA Technologies published the following solutions to address the vulnerabilities:

robot_update patches 7.97HF8 (or above), 9.20HF9 (or above), and 9.20SHF9 (or above)

Note: UIM 8.5.1 users must upgrade robot to 7.97HF8.

Hotfixes are available at:

https://techdocs.broadcom.com/us/product-content/recommended-reading/technical-document-index/ca-unified-infrastructure-management-hotfix-index.html

References

CVE-2020-8010 – CA UIM Probe Improper ACL Handling RCE

CVE-2020-8011 – CA UIM Improper Probe Handling NPD DoS

CVE-2020-8012 – CA UIM nimbuscontroller Buffer Overflow RCE

Common Vulnerabilityies and Exposures

Contact us to get started

CVE-2022-1840 : Home Clean Services Management System Stored Cross-Site Scripting (XSS)

CVE-2022-1840 : Home Clean Services Management System Stored Cross-Site Scripting (XSS)

Description Persistent XSS (or Stored XSS) attack is one of the three major categories of XSS attacks, the others being

CVE-2022-1558 : Multiple Stored Cross-Site Scripting vulnerabilities in WordPress curtain plugin 1.0.2

CVE-2022-1558 : Multiple Stored Cross-Site Scripting vulnerabilities in WordPress curtain plugin 1.0.2

Description Several Cross-Site Scripting vulnerabilities in the Curtain WordPress plugin. Due to these Cross-Site Scripting vulnerabilities, an attacker would be

CVE-2022-AVAST2 : Self-Defense Bypass via Repairing Function

CVE-2022-AVAST2 : Self-Defense Bypass via Repairing Function

Description It was noted that there is security checking to prevent some of the Avast processes from loading of undesired/unsigned