CVE-2022-39395 : VELA SERVER/WORKER/UI PRIVILEGES MANAGEMENT

Description

Vela is a Pipeline Automation (CI/CD) framework built on Linux container technology written in Golang. In Vela Server and Vela Worker prior to version 0.16.0 and Vela UI prior to version 0.17.0, some default configurations for Vela allow exploitation and container breakouts. Users should upgrade to Server 0.16.0, Worker 0.16.0, and UI 0.17.0 to fix the issue. After upgrading, Vela administrators will need to explicitly change the default settings to configure Vela as desired. Some of the fixes will interrupt existing workflows and will require Vela administrators to modify default settings. However, not applying the patch (or workarounds) will continue existing risk exposure. Some workarounds are available. Vela administrators can adjust the worker’s `VELA_RUNTIME_PRIVILEGED_IMAGES` setting to be explicitly empty, leverage the `VELA_REPO_ALLOWLIST` setting on the server component to restrict access to a list of repositories that are allowed to be enabled, and/or audit enabled repositories and disable pull_requests if they are not needed.

References

https://github.com/go-vela/server/security/advisories/GHSA-5m7g-pj8w-7593

https://docs.docker.com/engine/security/#docker-daemon-attack-surface

https://github.com/go-vela/server/commit/05558ee99d70f7d6f83bed7c8f78ac0b35fa26f4

https://github.com/go-vela/server/releases/tag/v0.16.0

https://github.com/go-vela/ui/releases/tag/v0.17.0

https://github.com/go-vela/ui/security/advisories/GHSA-xf39-98m2-889v

https://github.com/go-vela/worker/releases/tag/v0.16.0

https://github.com/go-vela/worker/security/advisories/GHSA-2w78-ffv6-p46w

https://go-vela.github.io/docs/installation/server/reference/#vela_repo_allowlist

https://go-vela.github.io/docs/installation/worker/reference/#vela_runtime_privileged_images

For More Information

MITRE

Common Vulnerabilityies and Exposures

Contact us to get started

CVE-2024-3400 : PALO ALTO NETWORKS PAN-OS GLOBALPROTECT COMMAND INJECTION

CVE-2024-3400 : PALO ALTO NETWORKS PAN-OS GLOBALPROTECT COMMAND INJECTION

Description A command injection vulnerability in the GlobalProtect feature of Palo Alto Networks PAN-OS software for specific PAN-OS versions and

CVE-2024-21508 : MYSQL2 UP TO 3.9.3 READCODEFOR BIGNUMBERSTRINGS CODE INJECTION

CVE-2024-21508 : MYSQL2 UP TO 3.9.3 READCODEFOR BIGNUMBERSTRINGS CODE INJECTION

Description Versions of the package mysql2 before 3.9.4 are vulnerable to Remote Code Execution (RCE) via the readCodeFor function due

CVE-2024-30729 : ROS KINETIC KAME 1 OS COMMAND INJECTION

CVE-2024-30729 : ROS KINETIC KAME 1 OS COMMAND INJECTION

Description An OS command injection vulnerability has been discovered in ROS Kinetic Kame in ROS_VERSION 1 and ROS_ PYTHON_VERSION 3,