Overview :
Cloud Foundry NFS Volume Service, 1.7.x versions prior to 1.7.11 and 2.x versions prior to 2.3.0, is vulnerable to LDAP injection. A remote authenticated malicious space developer can potentially inject LDAP filters via service instance creation, facilitating the malicious space developer to deny service or perform a dictionary attack.
Affected Product(s) :
  • Cloud Foundry NFS Volume Service, 1.7.x versions prior to 1.7.11 and 2.x versions prior to 2.3.0
Vulnerability Details :
CVE ID :CVE-2019-11277
 Lead the malicious space developer to deny service or perform a dictionary attack.

Solution :

Users of affected products are strongly encouraged to follow the mitigations below. The Cloud Foundry project recommends upgrading the following releases:

  • CF Deployment
    • Upgrade All versions to v11.1.0 or greater
  • CF NFS volume release
    • Upgrade 1.7 versions to v1.7.11 or greater
    • Upgrade 2.x versions to v2.3.0 or greater