phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability

Overview :
In phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability was found in retrieval of the current username (in libraries/classes/Server/Privileges.php and libraries/classes/UserPassword.php). A malicious user with access to the server could create a crafted username, and then trick the victim into performing specific actions with that user account (such as editing its privileges).

CVE-2020-10804

PMASA-2020-2

Announcement-ID: PMASA-2020-2

Date: 2020-03-20

Updated: 2020-03-22

Summary

SQL injection with processing username

Description

An SQL injection vulnerability was found in how phpMyAdmin retrieves the current username.

A malicious user with access to the server could create a specially-crafted username and then trick the victim in to performing specific actions with that user account (such as editing its privileges).

This flaw also could generate server errors for users with certain characters who try to change their MySQL passwords.

Severity

Because of the specific steps required to exploit this, we consider this vulnerability to be of moderate severity

Affected Versions

phpMyAdmin 4.9.x releases prior to 4.9.5 and the 5.0.x releases prior to 5.0.2 are affected.

Solution

Upgrade to phpMyAdmin 4.9.5 or 5.0.2 or newer or apply patch listed below.

References

Thanks to hoangn144_VCS and bluebird for reporting these vulnerabilities.

Assigned CVE ids: CVE-2020-10804

CWE ids: CWE-661

Patches

The following commits have been made to fix this issue:

More information

For further information and in case of questions, please contact the phpMyAdmin team. Our website is phpmyadmin.net.

Common Vulnerabilityies and Exposures

Contact us to get started

CVE-2022-37708 : DOCKER 20.10.15 BUILD FD82621 PERMISSION

CVE-2022-37708 : DOCKER 20.10.15 BUILD FD82621 PERMISSION

Description Docker version 20.10.15, build fd82621 is vulnerable to Insecure Permissions. Unauthorized users outside the Docker container can access any

CVE-2023-0240 : LINUX KERNEL UP TO 5.10.160 IO_URING IO_PREP_ASYNC_WORK USE AFTER FREE

CVE-2023-0240 : LINUX KERNEL UP TO 5.10.160 IO_URING IO_PREP_ASYNC_WORK USE AFTER FREE

Description There is a logic error in io_uring’s implementation which can be used to trigger a use-after-free vulnerability leading to

CVE-2023-0556 : CONTENTSTUDIO PLUGIN UP TO 1.2.5 ON WORDPRESS CSTU_GET_METADATA AUTHORIZATION

CVE-2023-0556 : CONTENTSTUDIO PLUGIN UP TO 1.2.5 ON WORDPRESS CSTU_GET_METADATA AUTHORIZATION

Description The ContentStudio plugin for WordPress is vulnerable to authorization bypass due to a missing capability check on several functions