CVE-2021-32702

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users. (CVSS:0.0) (Last Update:2021-06-25)

Common Vulnerabilityies and Exposures

Contact us to get started

CVE-2022-32532 : APACHE SHIRO UP TO 1.9.0 REGEXREQUESTMATCHER AUTHORIZATION

CVE-2022-32532 : APACHE SHIRO UP TO 1.9.0 REGEXREQUESTMATCHER AUTHORIZATION

Description Apache Shiro before 1.9.1, A RegexRequestMatcher can be misconfigured to be bypassed on some servlet containers. Applications using RegExPatternMatcher

CVE-2022-31104 : WASMTIME CALCULATION

CVE-2022-31104 : WASMTIME CALCULATION

Description Wasmtime is a standalone runtime for WebAssembly. In affected versions wasmtime’s implementation of the SIMD proposal for WebAssembly on

CVE-2022-33146 : WEB2PY UP TO 2.22.4 URL REDIRECT

CVE-2022-33146 : WEB2PY UP TO 2.22.4 URL REDIRECT

Description Open redirect vulnerability in web2py versions prior to 2.22.5 allows a remote attacker to redirect a user to an