Overview :
A cross site scripting security vulnerability has been identified with Case Builder component in IBM Case Manager
Affected Product(s) :
  • IBM Case Manager 5.1.1
  • IBM Case Manager 5.2.0
  • IBM Case Manager 5.2.1
  • IBM Case Manager 5.3CD
Vulnerability Details :
CVE ID :CVE-2019-4426
Case Builder component shipped in IBM Case Manager is vulnerable to cross-site scripting. This vulnerability allows users to embed arbitrary JavaScript code in the Web UI thus altering the intended functionality potentially leading to credentials disclosure within a trusted session.

Solution :

The recommended solution is to apply the Interim Fix (iFix) or Cumulative Fix (CF) containing

APAR PJ45724 as soon as practical:

  • IBM Case Manager

For IBM Case Manager 5.3CD
· Upgrade to at least IBM 5.3.2 as required by iFix and then apply iFix that includes APAR PJ45724
–OR–
· Upgrade to Business Automation Workflow V19.0.0.3

IBM Case Manager V5.1.1, V5.2.0, and V5.2.1 are no longer in full support; IBM recommends upgrading to a fixed, supported version/release/platform of the product.